Request
Make a call:
  • Between two analog phones
  • Between the Site or other softphone Site
  • Between analog phones and softphone.
Note: Part of this practice can split or combine all 3 of the above.

Implementation:

  • Brekeke SIP Server configuration:
After successful installation continues to configure the following steps:
1.Them user accounts, where username is your phone number will be assigned to a specific user



Checking accounts are created in the View tab User



2.Thuc the Dial Plan
In the case of calls between softphones do not need this step, but if you want to call a phone number they need to build analog Dial Plan will build two dialing rules as follows:
Ø If you press "0" on the softphone, the call will be sent to R1.
Ø If you press 3 on the softphone, the call will be forwarded to R2
For example, to call 201, the need to press EX 0201, EX 301 call, press 3301.
To see more about Dial Plan can be found on http://www.brekeke.com/



Dial Plan check was made



B. Router configuration

R1 # sh run
Code:
Building configuration ...
   !
   More
   !
   !
   interface Ethernet0 / 0
    ip address 192.168.0.1 255.255.255.0
    half-duplex
   !
   interface Serial0 / 0
    no ip address
    shutdown
    no fair-queue
   !
   interface Serial0 / 1
    bandwidth 256
    ip address 192.168.1.1 255.255.255.0
    clockrate 256,000
   !
   ip http server
   ip classless
   ip route 0.0.0.0 0.0.0.0 192.168.1.2
   !
   voice-port 1/0/0
   !
   voice-port 1/0/1
   !
   MGCP default profile
   !
   dial-peer cor custom
   !
   dial-peer voice 1 pots
    destination-pattern 201
    port 1/0/0
   !
   dial-peer voice 2 voip
    destination-pattern 3 .. / / Any string of numbers beginning with ceramic 3 3
    session target ipv4: 192.168.1.2 
   !
   dial-peer voice 3 voip
    destination-pattern 1 .. / / Any string of numbers beginning with ceramic 3 1
    session protocol sipv2 / / protocol between Router and Signal SIP Server
    session target ipv4: 192.168.0.2 / / SIP Server Address
    g711alaw codec / / SIP Server only supports G711 Codec type
   !
   end 

R2 # show run
Code:
Building configuration ...
   !
   More
   !
   interface Ethernet0 / 0
    ip address 192.168.2.1 255.255.255.0
    half-duplex
   !
   interface Serial0 / 0
    bandwidth 256
    ip address 192.168.1.2 255.255.255.0
   !
   ip http server
   no ip http secure-server
   ip classless
   ip route 0.0.0.0 0.0.0.0 192.168.1.1
   !
   !
   !
   !
   voice-port 1/1/0
   !
   voice-port 1/1/1
   !
   !
   !
   dial-peer voice 1 pots
    destination-pattern 301
    port 1/1/0
   !
   dial-peer voice 2 voip
    destination-pattern 2 .. / / Any string of numbers beginning with ceramic 3 2
   
    session target ipv4: 192.168.1.1
   !
   dial-peer voice 3 voip
    destination-pattern 1 .. / / Any string of numbers beginning with ceramic 3 1
   
    session protocol sipv2 / / protocol between Router and Signal SIP Server
    session target ipv4: 192.168.0.2 / / SIP Server Address
    g711alaw codec / / SIP Server only supports G711 Codec type
   !
   !
   line con 0
   line aux 0
   line vty 0 4
    privilege level 15
    no login
   !
   !
   end
   
   R2 # 

C. Softphone configuration

Soft phone program that we will use X-Lite, a few more configuration parameters to allow communication with the Brekeke SIP Server
User Name and Password must match the information on the Server
Domain: Brekeke SIP Server's Address


If matching information and softphone communicate with Server, the screen will display the username of the user.
 upanh


Results displayed when making calls in the Active Sessions tab from the 102 to 101