Search This Blog

Oct 5, 2010

Lab 1-2: Configuring IP UNNUMBERED



On the Cisco router, each port connected to a network segment must belong to a separate subnet. Routers connected directly to each other will be the gateway IP address assigned to the same subnet. If a router needs to send data to the network does not connect directly, it see the routing table and forwards the packet to the next station (next-hop) towards the destination. If no route in the routing table, the router forwards the packet to the default router address. 






Each point-point connection (point-to-point) only 2 addresses, to save address space can borrow the IP address of a LAN port to the source address (source address) for information update routing information (routing update). 
¤ The routing protocols will have different ways for different activities unnumber interfaces. For example, OSPF will work if both peers are configured unnumbered. In cases where only one is unnumbered routers, OSPF neighbor relationships will not be set. The routing protocols such as ISIS, EIGRP, BGP will have different ways to treat the unnumbered port.The only disadvantage of the unnumbered interface is not capable of checking (testing and management). Also, unnumbered connection only works on point-to-point. 


The following examples configure IP unnumbered to consider the cases of different IP address in Ethernet port. 

Case 1: The subnet of the same major network connectivity via serial port 




R0 
! 
hostname R0 
! 
ip subnet-zero 
! 
interface Serial0 / 0 
ip unnumbered Ethernet1 / 0 
! 
interface Ethernet1 / 0 
ip address 172.16.10.196 255 255 255 192 
! 
router IGRP 10 
network 172.16.0.0 
! 
ip classless 
! 
line con 0 
transport input none 
line aux 0 
line vty 0 4 
! 
end 
R1 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
ip address 172.16.1.1 255 255 255 192 
! 
interface Serial1 
ip unnumbered Ethernet0 
clockrate 64000 
! 
router IGRP 10 
network 172.16.0.0 
ip classless 
! 
line con 0 
transport input none 
line aux 0 
line vty 0 4 
! 
end 

Check 

R0 # sh ip ro 
Gateway of last resort is not set 
172.16.0.0/26 is subnetted, 3 subnets 
C 172.16.10.192 is directly connected, Ethernet1 / 0 
I 172.16.0.0 [100/80225] via 172.16.1.1, 00:00:39, Serial0 / 0 
I 172.16.1.0 [100/80225] via 172.16.1.1, 00:00:39, Serial0 / 0 
R0 # ping 172.16.1.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5 / 5), round-trip min / avg / max = 36/40/56 ms 
R1 # sh ip route 
Gateway of last resort is not set 
172.16.0.0/26 is subnetted, 3 subnets 
I 172.16.10.192 [100/8576] via 172.16.10.196, 00:00:00, Serial1 
I 172.16.0.0 [100/8576] via 172.16.10.196, 00:00:00, Serial1 
C 172.16.1.0 is directly connected, Ethernet0 
R1 # ping 172.16.10.196 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.10.196, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5 / 5), round-trip min / avg / max = 32/32/32 ms 

Case 2: The major difference network connected via serial port with the same subnet mask 




R0 
! 
interface Ethernet1 / 0 
ip address 170.16.10.196 255.255.0.0 
no keepalive 
! 
interface Serial0 / 0 
ip unnumbered Ethernet1 / 0 
! 
router IGRP 10 
network 170.16.0.0 
R1 
! 
interface Ethernet0 
ip address 172.16.1.1 255.255.0.0 
no keepalive 
! 
interface Serial1 
ip unnumbered Ethernet0 
clockrate 64000 
! 
router IGRP 10 
network 172.16.0.0 

R0 # sh ip ro 
Gateway of last resort is not set 
C 170.16.0.0/16 is directly connected, Ethernet1 / 0 
I 172.16.0.0/16 [100/80225] via 172.16.1.1, 00:00:35, Serial0 / 0 
R0 # ping 172.16.1.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5 / 5), round-trip min / avg / max = 28/29/32 ms 
R1 # sh ip ro 
Gateway of last resort is not set 
I 170.16.0.0/16 [100/8576] via 170.16.10.196, 00:00:27, Serial1 
C 172.16.0.0/16 is directly connected, Ethernet0 
R1 # ping 170.16.10.196 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 170.16.10.196, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5 / 5), round-trip min / avg / max = 28/30/32 ms 

Case 3: The different subnet with a subnet mask, the other major networks 





R0 
! 
interface Serial0 / 0 
ip unnumbered Ethernet1 / 0 
! 
interface Ethernet1 / 0 
ip address 170.16.10.196 255 255 255 192 
no keepalive 
! 
router IGRP 10 
network 170.16.0.0 
! 
R1 
! 
interface Ethernet0 
ip address 172.16.1.1 255.255.0.0 
no keepalive 
! 
interface Serial1 
ip unnumbered Ethernet0 
clockrate 64000 
! 
router IGRP 10 
network 172.16.0.0 
! 

R0 # sh ip ro 
Gateway of last resort is not set 
170.16.0.0/26 is subnetted, 1 subnets 
170.16.10.192 C is directly connected, Ethernet1 / 0 
I 172.16.0.0/16 [100/80225] via 172.16.1.1, 00:00:22, Serial0 / 0 
R1 # show ip route 
Gateway of last resort is not set 
170.16.0.0/16 is variably subnetted, 2 subnets, 2 masks 
I 170.16.10.192/32 [100/8576] via 170.16.10.196, 00:00:35, Serial1 
I 170.16.0.0/16 [100/8576] via 170.16.10.196, 00:00:35, Serial1 
C 172.16.0.0/16 is directly connected, Ethernet0 
R1 # ping 170.16.10.196 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 170.16.10.196, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5 / 5), round-trip min / avg / max = 32/32/32 ms 

Case 4: The subnet and subnet mask of the different major network 





R0 
! 
interface Serial0 / 0 
ip unnumbered Ethernet1 / 0 
! 
interface Ethernet1 / 0 
ip address 170.16.10.196 255 255 255 192 
! 
router IGRP 10 
network 170.16.0.0 
! 
R1 
! 
interface Ethernet0 
ip address 172.16.1.1 255 255 255 192 
! 
interface Serial1 
ip unnumbered Ethernet0 
clockrate 64000 
! 
router IGRP 10 
network 172.16.0.0 
! 

R1 # sh ip ro 
Gateway of last resort is not set 
170.16.0.0/16 is variably subnetted, 2 subnets, 2 masks 
I 170.16.10.192/32 [100/8576] via 170.16.10.196, 00:00:01, Serial1 
I 170.16.0.0/16 [100/8576] via 170.16.10.196, 00:00:01, Serial1 
172.16.0.0/26 is subnetted, 1 subnets 
C 172.16.1.0 is directly connected, Ethernet0 
R0 # sh ip Rou 
Gateway of last resort is not set 
170.16.0.0/26 is subnetted, 1 subnets 
C 170.16.10.192 is directly connected, Ethernet1 / 0 
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks 
I 172.16.0.0/16 [100/80225] via 172.16.1.1, 00:00:17, Serial0 / 0 
I 172.16.1.0/32 [100/80225] via 172.16.1.1, 00:00:17, Serial0 / 0 
R0 # ping 172.16.1.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5 / 5), round-trip min / avg / max = 28/30/32 ms