Search This Blog

Oct 17, 2010

BCRAN challenging lab 2

hostname R1
!
aaa new-model
aaa authentication login default local
aaa authorization commands 7 default local
enable password cisco
 !
username minhdq privilege 7 password 0 vnpro
!
interface Loopback0
ip address 20.0.0.1 255.255.255.252
no keepalive
!
interface Ethernet0/0
ip address 150.50.17.1 255.255.255.0
half-duplex
!
router rip
version 2
network 150.50.0.0
network 200.0.0.0
!
ip classless
privilege configure level 7 conf t
!
line con 0
exec-timeout 0 0
password cisco
logging synchronous
transport input none
line aux 0
exec-timeout 0 0
password cisco
line vty 0 4
password cisco
!
no scheduler allocate
end
 R1#show ip ro

200.0.0.0/32 is subnetted, 3 subnets
R 200.0.0.9 [120/2] via 150.50.17.2, 00:00:11, Ethernet0/0
R 200.0.0.5 [120/2] via 150.50.17.2, 00:00:11, Ethernet0/0
R 200.0.0.7 [120/2] via 150.50.17.2, 00:00:11, Ethernet0/0
20.0.0.0/30 is subnetted, 1 subnets
C 20.0.0.0 is directly connected, Loopback0
150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
R 150.50.6.128/25 [120/2] via 150.50.17.2, 00:00:11, Ethernet0/0
R 150.50.6.0/25 [120/2] via 150.50.17.2, 00:00:11, Ethernet0/0
R 150.50.7.0/25 [120/2] via 150.50.17.2, 00:00:11, Ethernet0/0
C 150.50.17.0/24 is directly connected, Ethernet0/0
R 150.50.24.0/24 [120/2] via 150.50.17.2, 00:00:11, Ethernet0/0
R 150.50.24.0/27 [120/1] via 150.50.17.2, 00:00:11, Ethernet0/0
150.50.25.0/27 [120/1] via 150.50.17.2, 00:00:13, Ethernet0/0
R 150.50.26.0/27 [120/1] via 150.50.17.2, 00:00:13, Ethernet0/0
R 150.50.5.64/27 [120/2] via 150.50.17.2, 00:00:13, Ethernet0/0
R1#


hostname R2
!
logging rate-limit console 10 except errors
enable password cisco
!
username R5 password 0 cisco
isdn switch-type basic-ni
!
interface Ethernet0/0
ip address 150.50.17.2 255.255.255.0
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
backup delay 5 30
backup interface BRI0/0
ip address 150.50.25.2 255.255.255.224
frame-relay interface-dlci 205
!
interface Serial0/0.2 point-to-point
ip address 150.50.24.2 255.255.255.224
frame-relay interface-dlci 204
!
interface Serial0/0.3 point-to-point
ip address 150.50.26.2 255.255.255.224
frame-relay interface-dlci 206
!
interface BRI0/0
ip address 150.50.9.2 255.255.255.192
encapsulation ppp
dialer idle-timeout 60
dialer map ip 150.50.9.5 name R5 broadcast 8995101
dialer map ip 150.50.9.5 name R5 broadcast 8995102
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5201 8995201
isdn spid2 5202 8995202
ppp authentication chap
!
router ospf 50
log-adjacency-changes
redistribute rip metric 100 subnets
passive-interface BRI0/0
network 150.50.24.0 0.0.0.31 area 0
network 150.50.25.0 0.0.0.31 area 0
network 150.50.26.0 0.0.0.31 area 0
!
router rip
version 2
redistribute ospf 50 metric 2
network 150.50.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.50.9.5 150
no ip http server
!
dialer-list 1 protocol ip permit
!
!
line con 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password cisco
login
!
no scheduler allocate
end

R2#show ip ro

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 3 subnets
O E2 200.0.0.9 [110/90] via 150.50.26.6, 00:04:26, Serial0/0.3
O 200.0.0.5 [110/65] via 150.50.25.5, 00:04:26, Serial0/0.1
O 200.0.0.7 [110/75] via 150.50.26.6, 00:04:26, Serial0/0.3
150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
O E2 150.50.6.128/25 [110/90] via 150.50.26.6, 00:04:26, Serial0/0.3
O E2 150.50.6.0/25 [110/90] via 150.50.26.6, 00:04:26, Serial0/0.3
O 150.50.7.0/25 [110/74] via 150.50.26.6, 00:04:26, Serial0/0.3
C 150.50.17.0/24 is directly connected, Ethernet0/0
O 150.50.24.0/24 [110/128] via 150.50.24.4, 00:04:26, Serial0/0.2
C 150.50.24.0/27 is directly connected, Serial0/0.2
C 150.50.25.0/27 is directly connected, Serial0/0.1
C 150.50.26.0/27 is directly connected, Serial0/0.3
O 150.50.5.64/27 [110/138] via 150.50.26.6, 00:04:28, Serial0/0.3


hostname R4
!
enable password cisco
!
username R4 password 0 cisco
!
policy-map CBWFQ
!
interface Loopback0
ip address 200.0.0.4 255.255.255.255
!
interface Ethernet0/0
ip address 10.1.1.4 255.255.255.0
half-duplex
no keepalive
!
interface Serial0/0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
!
interface Serial0/0.42 point-to-point
ip address 150.50.24.4 255.255.255.0
frame-relay class FRTS
frame-relay interface-dlci 402
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.255 area 0
network 150.50.24.0 0.0.0.31 area 0
!
ip http server
ip classless
!
map-class frame-relay FRTS
frame-relay cir 32000
frame-relay mincir 8000
frame-relay adaptive-shaping becn
service-policy output CBWFQ
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
!
end

R4#show ip ro

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 4 subnets
O E2 200.0.0.9 [110/90] via 150.50.24.2, 00:05:11, Serial0/0.42
C 200.0.0.4 is directly connected, Loopback0
O 200.0.0.5 [110/129] via 150.50.24.2, 00:05:11, Serial0/0.42
O 200.0.0.7 [110/139] via 150.50.24.2, 00:05:11, Serial0/0.42
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Ethernet0/0
150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
O E2 150.50.6.128/25 [110/90] via 150.50.24.2, 00:05:11, Serial0/0.42
O E2 150.50.6.0/25 [110/90] via 150.50.24.2, 00:05:11, Serial0/0.42
O 150.50.7.0/25 [110/138] via 150.50.24.2, 00:05:11, Serial0/0.42
O E2 150.50.17.0/24 [110/100] via 150.50.24.2, 00:05:11, Serial0/0.42
O 150.50.24.0/27 [110/128] via 150.50.24.2, 00:05:11, Serial0/0.42
150.50.24.0/24 is directly connected, Serial0/0.42
O 150.50.25.0/27 [110/128] via 150.50.24.2, 00:05:13, Serial0/0.42
O 150.50.26.0/27 [110/128] via 150.50.24.2, 00:05:13, Serial0/0.42
O 150.50.5.64/27 [110/202] via 150.50.24.2, 00:05:13, Serial0/0.42
R4#



hostname R5
!
logging rate-limit console 10 except errors
!
username R2 password 0 cisco
isdn switch-type basic-ni
!
interface Loopback0
ip address 200.0.0.5 255.255.255.255
!
interface Ethernet0/0
ip address 150.50.7.5 255.255.255.128
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0/0.52 point-to-point
backup delay 5 30
backup interface BRI0/0
ip address 150.50.25.5 255.255.255.224
frame-relay interface-dlci 502
!
interface BRI0/0
ip address 150.50.9.5 255.255.255.192
encapsulation ppp
dialer idle-timeout 30 either
dialer map ip 150.50.9.2 name R2 8995201
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101 8995101
isdn spid2 5102 8995102
ppp authentication chap
ppp multilink
!
router ospf 64
log-adjacency-changes
passive-interface BRI0/0
network 150.50.7.0 0.0.0.127 area 0
network 150.50.9.0 0.0.0.63 area 0
network 150.50.25.0 0.0.0.31 area 0
network 200.0.0.5 0.0.0.0 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.50.9.2 150
no ip http server
!
dialer-list 1 protocol ip permit
!
end

R5#show ip ro


200.0.0.0/32 is subnetted, 3 subnets
O E2 200.0.0.9 [110/90] via 150.50.25.2, 00:05:50, Serial0/0.52
C 200.0.0.5 is directly connected, Loopback0
O 200.0.0.7 [110/139] via 150.50.25.2, 00:05:50, Serial0/0.52
150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
O E2 150.50.6.128/25 [110/90] via 150.50.25.2, 00:05:50, Serial0/0.52
O E2 150.50.6.0/25 [110/90] via 150.50.25.2, 00:05:50, Serial0/0.52
O 150.50.7.0/25 [110/138] via 150.50.25.2, 00:05:50, Serial0/0.52
O E2 150.50.17.0/24 [110/100] via 150.50.25.2, 00:05:50, Serial0/0.52
O 150.50.24.0/24 [110/192] via 150.50.25.2, 00:05:50, Serial0/0.52
O 150.50.24.0/27 [110/128] via 150.50.25.2, 00:05:50, Serial0/0.52
C 150.50.25.0/27 is directly connected, Serial0/0.52
O 150.50.26.0/27 [110/128] via 150.50.25.2, 00:05:50, Serial0/0.52
O 150.50.5.64/27 [110/202] via 150.50.25.2, 00:05:52, Serial0/0.52
R5#



hostname R6
!
enable password cisco
!
class-map FTP-CLASS
match access-group 110
class-map HTTP-CLASS
match access-group 120
!
!
policy-map CBWFQ-CENTRAL
class FTP-CLASS
bandwidth percent 20
class HTTP-CLASS
bandwidth percent 10
!
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 150.50.7.6 255.255.255.128
service-policy output CBWFQ-CENTRAL
!
interface Ethernet1
ip address 150.50.6.6 255.255.255.128
!
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
!
interface Serial0.62 point-to-point
ip address 150.50.26.6 255.255.255.224
frame-relay class MYSHAPING
frame-relay interface-dlci 602
!
router eigrp 100
redistribute ospf 1 metric 255 255 255 128 15000
network 150.50.6.0 0.0.0.127
no auto-summary
no eigrp log-neighbor-changes
!
router ospf 1
log-adjacency-changes
redistribute eigrp 100 metric 90 subnets
network 150.50.7.0 0.0.0.127 area 0
network 150.50.26.0 0.0.0.31 area 0
!
ip classless
no ip http server
!
!
map-class frame-relay MYSHAPING
frame-relay traffic-rate 256000 256000
no frame-relay adaptive-shaping
frame-relay bc 1000
frame-relay be 0
frame-relay mincir 256000
access-list 110 permit tcp any any eq ftp
access-list 120 permit tcp any any eq www
!
line con 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end

R6#show ip ro

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 3 subnets
D 200.0.0.9 [90/409600] via 150.50.6.9, 00:58:48, Ethernet1
O 200.0.0.5 [110/129] via 150.50.26.2, 00:06:16, Serial0.62
O 200.0.0.7 [110/11] via 150.50.7.7, 00:06:16, Ethernet0
150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
D 150.50.6.128/25 [90/409600] via 150.50.6.9, 00:58:49, Ethernet1
C 150.50.6.0/25 is directly connected, Ethernet1
C 150.50.7.0/25 is directly connected, Ethernet0
O E2 150.50.17.0/24 [110/100] via 150.50.26.2, 00:06:17, Serial0.62
O 150.50.24.0/24 [110/192] via 150.50.26.2, 00:06:17, Serial0.62
O 150.50.24.0/27 [110/128] via 150.50.26.2, 00:06:17, Serial0.62
O 150.50.25.0/27 [110/128] via 150.50.26.2, 00:06:17, Serial0.62
C 150.50.26.0/27 is directly connected, Serial0.62
O 150.50.5.64/27 [110/74] via 150.50.7.7, 00:06:18, Ethernet0
R6#


hostname R7
!
enable password cisco
!
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
interface Loopback0
ip address 200.0.0.7 255.255.255.255
!
interface Ethernet0/0
ip address 150.50.7.7 255.255.255.128
half-duplex
!
interface Serial0/0
ip address 150.50.5.68 255.255.255.224
no fair-queue
!
!
router ospf 50
log-adjacency-changes
network 150.50.5.64 0.0.0.31 area 0
network 150.50.7.0 0.0.0.127 area 0
network 200.0.0.7 0.0.0.0 area 0
!
ip classless
!
dial-peer cor custom
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
no scheduler allocate
!
end

R7#show ip ro

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 3 subnets
O E2 200.0.0.9 [110/90] via 150.50.7.6, 00:00:16, Ethernet0/0
O 200.0.0.5 [110/11] via 150.50.7.5, 00:00:16, Ethernet0/0
C 200.0.0.7 is directly connected, Loopback0
150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
O E2 150.50.6.128/25 [110/90] via 150.50.7.6, 00:00:16, Ethernet0/0
O E2 150.50.6.0/25 [110/90] via 150.50.7.6, 00:00:16, Ethernet0/0
C 150.50.7.0/25 is directly connected, Ethernet0/0
O E2 150.50.17.0/24 [110/100] via 150.50.7.6, 00:00:16, Ethernet0/0
[110/100] via 150.50.7.5, 00:00:16, Ethernet0/0
O 150.50.24.0/24 [110/202] via 150.50.7.6, 00:00:16, Ethernet0/0
[110/202] via 150.50.7.5, 00:00:16, Ethernet0/0
O 150.50.24.0/27 [110/138] via 150.50.7.6, 00:00:16, Ethernet0/0
[110/138] via 150.50.7.5, 00:00:16, Ethernet0/0
O 150.50.25.0/27 [110/74] via 150.50.7.5, 00:00:17, Ethernet0/0
O 150.50.26.0/27 [110/74] via 150.50.7.6, 00:00:17, Ethernet0/0
C 150.50.5.64/27 is directly connected, Serial0/0
R7#


hostname R8
!
logging rate-limit console 10 except errors
enable secret 5 $1$4uiO$YRKyb370a5nYcRY191yik1
!
ip subnet-zero
!
no ip finger
!
class-map match-all telnet
match access-group 103
class-map match-all mail
match access-group 102
match access-group 104
class-map match-all http
match access-group 100
class-map match-all ftp
match access-group 101
!
policy-map ser
class ftp
bandwidth percent 30
class telnet
bandwidth percent 15
class mail
bandwidth percent 30
policy-map ether
class http
bandwidth percent 10
class ftp
bandwidth percent 20
!
interface Loopback0
ip address 200.0.0.8 255.255.255.255
!
interface Ethernet0/0
ip address 150.50.4.8 255.255.255.0
ip nat inside
no keepalive
half-duplex
service-policy output ether
!
interface Serial0/0
ip address 150.50.5.69 255.255.255.224
ip nat outside
service-policy output ser
clockrate 4000000
!
interface Serial0/1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 150.50.5.0 0.0.0.255 area 0
!
ip nat translation tcp-timeout 28800
ip nat translation udp-timeout 28800
ip nat translation finrst-timeout 28800
ip nat translation dns-timeout 28800
ip nat inside source list 1 interface Serial0/0 overload
ip classless
no ip http server
!
access-list 1 permit 150.50.4.0 0.0.0.255
access-list 100 permit tcp any any eq www
access-list 101 permit tcp any any eq ftp
access-list 102 permit tcp any any eq pop3
access-list 103 permit tcp any any eq telnet
access-list 104 permit tcp any any eq smtp
!
!
line con 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password 7 02050D480809
logging synchronous
login
!
no scheduler allocate
end

R8#show ip ro

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 4 subnets
C 200.0.0.8 is directly connected, Loopback0
O E2 200.0.0.9 [110/90] via 150.50.5.68, 00:00:49, Serial0/0
O 200.0.0.5 [110/75] via 150.50.5.68, 00:00:49, Serial0/0
O 200.0.0.7 [110/65] via 150.50.5.68, 00:00:49, Serial0/0
150.50.0.0/16 is variably subnetted, 10 subnets, 3 masks
O E2 150.50.6.128/25 [110/90] via 150.50.5.68, 00:00:49, Serial0/0
C 150.50.4.0/24 is directly connected, Ethernet0/0
O E2 150.50.6.0/25 [110/90] via 150.50.5.68, 00:00:49, Serial0/0
O 150.50.7.0/25 [110/74] via 150.50.5.68, 00:00:49, Serial0/0
O E2 150.50.17.0/24 [110/100] via 150.50.5.68, 00:00:49, Serial0/0
O 150.50.24.0/24 [110/266] via 150.50.5.68, 00:00:49, Serial0/0
O 150.50.24.0/27 [110/202] via 150.50.5.68, 00:00:49, Serial0/0
O 150.50.25.0/27 [110/138] via 150.50.5.68, 00:00:51, Serial0/0
O 150.50.26.0/27 [110/138] via 150.50.5.68, 00:00:51, Serial0/0
C 150.50.5.64/27 is directly connected, Serial0/0
R8#


hostname R9
!
enable password vnpro
!
interface Loopback0
ip address 200.0.0.9 255.255.255.255
!
interface Loopback1
ip address 150.50.6.209 255.255.255.128
!
interface Ethernet0/0
ip address 150.50.6.9 255.255.255.128
half-duplex
!
router eigrp 100
network 150.50.6.0 0.0.0.127
network 150.50.6.128 0.0.0.127
network 200.0.0.9 0.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
line con 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password vnpro
login
!
no scheduler allocate
end

R9#show ip ro

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 3 subnets
C 200.0.0.9 is directly connected, Loopback0
D EX 200.0.0.5 [170/10129920] via 150.50.6.6, 00:07:03, Ethernet0/0
D EX 200.0.0.7 [170/10129920] via 150.50.6.6, 00:59:19, Ethernet0/0
150.50.0.0/16 is variably subnetted, 9 subnets, 3 masks
C 150.50.6.128/25 is directly connected, Loopback1
C 150.50.6.0/25 is directly connected, Ethernet0/0
D EX 150.50.7.0/25 [170/10129920] via 150.50.6.6, 01:53:20, Ethernet0/0
D EX 150.50.17.0/24 [170/10129920] via 150.50.6.6, 00:07:23, Ethernet0/0
D EX 150.50.24.0/24 [170/10129920] via 150.50.6.6, 00:07:23, Ethernet0/0
D EX 150.50.24.0/27 [170/10129920] via 150.50.6.6, 00:07:23, Ethernet0/0
D EX 150.50.25.0/27 [170/10129920] via 150.50.6.6, 00:07:23, Ethernet0/0
D EX 150.50.26.0/27 [170/10129920] via 150.50.6.6, 00:07:39, Ethernet0/0
D EX 150.50.5.64/27 [170/10129920] via 150.50.6.6, 00:59:20, Ethernet0/0
R9#