Building configuration ...

Version 1.12
!
hostname R1
!
crypto ISAKMP policy 10
hash md5
authentication pre-share
ISAKMP key crypto vnpro1 address 150.50.5.69
!
crypto ipsec transform-set ah-md5-hmac MYSET esp-des

!
crypto map ipsec-ISAKMP MYMAP 10
set peer 150.50.5.69
set transform-set MYSET
match address 113
!
ip address 200.0.0.1 255 255 255 255
!
Loopback1 interface
ip address 192.168.10.1 255.255.255.0
!
interface Ethernet0 / 0
ip address 150.50.17.1 255.255.255.0
half-duplex
crypto map MYMAP
!
router eigrp 100
network 150.50.17.0 0.0.0.255
network 200.0.0.1 0.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
!
access-list 113 permit ip 192.168.10.0 0.0.0.255 150.50.4.0 0.0.0.255
!
line con 0
logging synchronous
transport input none
line aux 0
line vty 0 4
password 7 00071A150754
login
!
no scheduler cấp phát
end

R1 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
D 200.0.0.8 [90/2861056] via 150.50.17.2, 00:02:57, Ethernet0 / 0
D EX 200.0.0.9 [170/2198016] via 150.50.17.2, 00:02:57, Ethernet0 / 0
C 200.0.0.1 is directly connected, Loopback0
D 200.0.0.2 [90/409600] via 150.50.17.2, 01:06:35, Ethernet0 / 0
D 200.0.0.4 [90/2323456] via 150.50.17.2, 00:03:51, Ethernet0 / 0
D 200.0.0.5 [90/2323456] via 150.50.17.2, 00:02:13, Ethernet0 / 0
D 200.0.0.7 [90/2349056] via 150.50.17.2, 00:02:57, Ethernet0 / 0
C 192.168.10.0/24 is directly connected, Loopback1
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2221056] via 150.50.17.2, 00:03:51, Ethernet0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32 [170/2198016] via 150.50.17.2, 00:02:57, Ethernet0 / 0
D 150.50.4.0/24 [90/2758656] via 150.50.17.2, 00:02:59, Ethernet0 / 0
D EX 150.50.6.0/25 [170/2198016] via 150.50.17.2, 00:02:59, Ethernet0 / 0
D 150.50.7.0/25 [90/2221056] via 150.50.17.2, 00:02:59, Ethernet0 / 0
D 150.50.9.0/26 [90/40537600] via 150.50.17.2, 01:06:37, Ethernet0 / 0
C 150.50.17.0/24 is directly connected, Ethernet0 / 0
D 150.50.24.0/24 [90/2195456] via 150.50.17.2, 00:03:59, Ethernet0 / 0
D 150.50.100.0/27 [90/2195456] via 150.50.17.2, 00:03:59, Ethernet0 / 0
D 150.50.5.64/27 [90/2733056] via 150.50.17.2, 00:02:59, Ethernet0 / 0


R2 # sh run
!
hostname R2
!
!
isdn switch-type basic-ni
!
interface Loopback0
ip address 200.0.0.2 255 255 255 255
!
interface Ethernet0 / 0
ip address 150.50.17.2 255.255.255.0
half-duplex
!
interface Serial0 / 0
no ip address
encapsulation frame-relay
!
Serial0/0.24 interface point-to-point
ip address 150.50.24.2 255.255.255.0
frame-relay interface-DLCI 204
!
Serial0/0.256 multipoint interface
ip address 150.50.100.2 255 255 255 224
no ip split-horizon
frame-relay map ip 150.50.100.5 205 broadcast
frame-relay map ip 150.50.100.6 206 broadcast
!
interface BRI0 / 0
ip address 150.50.9.2 255 255 255 192
encapsulation ppp
dialer callback-secure
dialer idle-timeout 90
dialer map ip 150.50.9.5 broadcast name R5 class dialback 8995101
dialer map ip 150.50.9.5 broadcast name R5 class dialback 8995102
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5201 8995201
isdn spid2 5202 8995202
ppp callback accept
ppp authentication chap
!
router eigrp 100
passive-interface BRI0 / 0
network 150.50.9.0 0.0.0.63
network 150.50.17.0 0.0.0.255
network 150.50.24.0 0.0.0.255
network 150.50.100.0 0.0.0.31
network 200.0.0.2 0.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
map-class dialer dialback
dialer callback-server username
dialer-list 1 protocol ip permit
!
line con 0
logging synchronous
transport input none
line aux 0
line vty 0 4
7 121A0C041104 password
login
!
end

R2 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
D 200.0.0.8 [90/2835456] via 150.50.100.6, 00:02:42, Serial0/0.256
[90/2835456] via 150.50.100.5, 00:02:42, Serial0/0.256
D EX 200.0.0.9 [170/2172416] via 150.50.100.6, 00:02:42, Serial0/0.256
D 200.0.0.1 [90/409600] via 150.50.17.1, 00:02:37, Ethernet0 / 0
C 200.0.0.2 is directly connected, Loopback0
D 200.0.0.4 [90/2297856] via 150.50.24.4, 00:02:37, Serial0/0.24
D 200.0.0.5 [90/2297856] via 150.50.100.5, 00:02:42, Serial0/0.256
D 200.0.0.7 [90/2323456] via 150.50.100.6, 00:02:42, Serial0/0.256
[90/2323456] via 150.50.100.5, 00:02:42, Serial0/0.256
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2195456] via 150.50.24.4, 00:02:37, Serial0/0.24
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32
[170/2172416] via 150.50.100.6, 00:02:44, Serial0/0.256
D 150.50.4.0/24 [90/2733056] via 150.50.100.6, 00:02:44, Serial0/0.256
[90/2733056] via 150.50.100.5, 00:02:44, Serial0/0.256
D EX 150.50.6.0/25 [170/2172416] via 150.50.100.6, 00:02:44, Serial0/0.256
D 150.50.7.0/25 [90/2195456] via 150.50.100.6, 00:02:44, Serial0/0.256
[90/2195456] via 150.50.100.5, 00:02:44, Serial0/0.256
C 150.50.9.0/26 is directly connected, BRI0 / 0
C 150.50.17.0/24 is directly connected, Ethernet0 / 0
C 150.50.24.0/24 is directly connected, Serial0/0.24
C 150.50.100.0/27 is directly connected, Serial0/0.256
D 150.50.5.64/27 [90/2707456] via 150.50.100.6, 00:02:44, Serial0/0.256
[90/2707456] via 150.50.100.5, 00:02:44, Serial0/0.256
R4 # sh run
!
hostname R4
!
no ip domain lookup
!
!
class-map match-all FTP-CLASS
match access-group 100
class-map match-any DEFAUTL
match any
class-map match-all ICMP-CLASS
match access-group 102
class-map match-all HTTP-CLASS
match access-group 101
!
policy-map CBWFQ-CENTRAL
class HTTP-CLASS
bandwidth 32
FTP-class CLASS
bandwidth 32
class ICMP-CLASS
bandwidth 32
DEFAUTL class
bandwidth 16
queue-limit 40
class class-default
!
interface Loopback0
ip address 200.0.0.4 255 255 255 255
!
interface Ethernet0 / 0
ip address 10.1.1.4 255.255.255.0
half-duplex
no keepalive
!
interface Serial0 / 0
no ip address
encapsulation frame-relay
!
Serial0/0.1 interface point-to-point
ip address 150.50.24.4 255.255.255.0
frame-relay interface-DLCI 402
!
interface Serial0 / 1
no ip address
shutdown
!
router eigrp 100
network 10.1.1.0 0.0.0.255
network 150.50.24.0 0.0.0.255
network 200.0.0.4 0.0.0.0
no auto-summary
!
ip http server
ip classless
access-list 100 permit tcp 172.16.136.0 0.0.0.255 10.1.1.0 0.0.0.255 eq ftp
access-list 100 permit tcp 172.16.136.0 0.0.0.255 10.1.1.0 0.0.0.255 eq ftp-data
access-list 101 permit tcp 172.16.136.0 0.0.0.255 10.1.1.0 0.0.0.255 eq www
access-list 102 permit icmp 172.16.136.0 0.0.0.255 10.1.1.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end

R4 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
D 200.0.0.8 [90/3347456] via 150.50.24.2, 00:04:04, Serial0/0.1
D EX 200.0.0.9 [170/2684416] via 150.50.24.2, 00:04:04, Serial0/0.1
D 200.0.0.1 [90/2323456] via 150.50.24.2, 00:05:00, Serial0/0.1
D 200.0.0.2 [90/2297856] via 150.50.24.2, 00:05:00, Serial0/0.1
C 200.0.0.4 is directly connected, Loopback0
D 200.0.0.5 [90/2809856] via 150.50.24.2, 00:03:21, Serial0/0.1
D 200.0.0.7 [90/2835456] via 150.50.24.2, 00:04:04, Serial0/0.1
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Ethernet0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32 [170/2684416] via 150.50.24.2, 00:04:04, Serial0/0.1
D 150.50.4.0/24 [90/3245056] via 150.50.24.2, 00:04:04, Serial0/0.1
D EX 150.50.6.0/25 [170/2684416] via 150.50.24.2, 00:04:06, Serial0/0.1
D 150.50.7.0/25 [90/2707456] via 150.50.24.2, 00:04:06, Serial0/0.1
D 150.50.9.0/26 [90/41024000] via 150.50.24.2, 00:05:03, Serial0/0.1
D 150.50.17.0/24 [90/2195456] via 150.50.24.2, 00:05:03, Serial0/0.1
C 150.50.24.0/24 is directly connected, Serial0/0.1
D 150.50.100.0/27 [90/2681856] via 150.50.24.2, 00:05:03, Serial0/0.1
D 150.50.5.64/27 [90/3219456] via 150.50.24.2, 00:04:07, Serial0/0.1

R4 # sh policy-map
Map CBWFQ policy-CENTRAL
HTTP Class-CLASS
Bandwidth 32 (kbps) Max Threshold 64 (packets)
Class FTP-CLASS
Bandwidth 32 (kbps) Max Threshold 64 (packets)
Class ICMP-CLASS
Bandwidth 32 (kbps) Max Threshold 64 (packets)
Class DEFAUTL
Bandwidth 16 (kbps) Max Threshold 40 (packets)
Class class-default

R4 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
D 200.0.0.8 [90/3347456] via 150.50.24.2, 00:04:40, Serial0/0.1
D EX 200.0.0.9 [170/2684416] via 150.50.24.2, 00:04:40, Serial0/0.1
D 200.0.0.1 [90/2323456] via 150.50.24.2, 00:05:36, Serial0/0.1
D 200.0.0.2 [90/2297856] via 150.50.24.2, 00:05:36, Serial0/0.1
C 200.0.0.4 is directly connected, Loopback0
D 200.0.0.5 [90/2809856] via 150.50.24.2, 00:03:56, Serial0/0.1
D 200.0.0.7 [90/2835456] via 150.50.24.2, 00:04:40, Serial0/0.1
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Ethernet0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32 [170/2684416] via 150.50.24.2, 00:04:40, Serial0/0.1
D 150.50.4.0/24 [90/3245056] via 150.50.24.2, 00:04:40, Serial0/0.1
D EX 150.50.6.0/25 [170/2684416] via 150.50.24.2, 00:04:41, Serial0/0.1
D 150.50.7.0/25 [90/2707456] via 150.50.24.2, 00:04:41, Serial0/0.1
D 150.50.9.0/26 [90/41024000] via 150.50.24.2, 00:05:37, Serial0/0.1
D 150.50.17.0/24 [90/2195456] via 150.50.24.2, 00:05:37, Serial0/0.1
C 150.50.24.0/24 is directly connected, Serial0/0.1
D 150.50.100.0/27 [90/2681856] via 150.50.24.2, 00:05:37, Serial0/0.1
D 150.50.5.64/27 [90/3219456] via 150.50.24.2, 00:04:41, Serial0/0.1

R5 # sh run
Building configuration ...
!
hostname R5
!
enable password cisco
!
username R2 password 0 cisco
isdn switch-type basic-ni
!
interface Loopback0
ip address 200.0.0.5 255 255 255 255
!
interface Ethernet0 / 0
ip address 150.50.7.5 255 255 255 128
half-duplex
!
interface Serial0 / 0
ip address 150.50.100.5 255 255 255 224
encapsulation frame-relay
no fair-queue
frame-relay class TSLAB
frame-relay traffic-shaping
!
interface BRI0 / 0
ip address 150.50.9.5 255 255 255 192
encapsulation ppp
dialer idle-timeout 60
dialer map ip 150.50.9.2 broadcast 8995201
dialer map ip 150.50.9.2 broadcast 8995202
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101
isdn spid2 5102
ppp callback request
ppp authentication chap
!
router eigrp 100
passive-interface BRI0 / 0
network 150.50.7.0 0.0.0.127
network 150.50.9.0 0.0.0.63
network 150.50.100.0 0.0.0.31
network 200.0.0.5 0.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip route 150.50.17.0 255.255.255.0 150.50.9.2 130
no ip http server
!
!
map-class frame-relay TSLAB
no frame-relay adaptive-shaping
frame-relay CIR 16000
frame-relay bc 2000
frame-relay be 2500
dialer-list 1 protocol ip permit
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
no scheduler cấp phát
end

R5 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
D 200.0.0.8 [90/2323456] via 150.50.7.7, 00:04:28, Ethernet0 / 0
D EX 200.0.0.9 [170/284160] via 150.50.7.6, 00:04:28, Ethernet0 / 0
D 200.0.0.1 [90/2323456] via 150.50.100.2, 00:04:38, Serial0 / 0
D 200.0.0.2 [90/2297856] via 150.50.100.2, 00:04:38, Serial0 / 0
D 200.0.0.4 [90/2809856] via 150.50.100.2, 00:04:38, Serial0 / 0
C 200.0.0.5 is directly connected, Loopback0
D 200.0.0.7 [90/409600] via 150.50.7.7, 00:04:28, Ethernet0 / 0
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2707456] via 150.50.100.2, 00:04:38, Serial0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32 [170/284160] via 150.50.7.6, 00:04:28, Ethernet0 / 0
D 150.50.4.0/24 [90/2221056] via 150.50.7.7, 00:04:28, Ethernet0 / 0
D EX 150.50.6.0/25 [170/284160] via 150.50.7.6, 00:04:30, Ethernet0 / 0
C 150.50.7.0/25 is directly connected, Ethernet0 / 0
C 150.50.9.0/26 is directly connected, BRI0 / 0
D 150.50.17.0/24 [90/2195456] via 150.50.100.2, 00:04:40, Serial0 / 0
D 150.50.24.0/24 [90/2681856] via 150.50.100.2, 00:04:40, Serial0 / 0
C 150.50.100.0/27 is directly connected, Serial0 / 0
D 150.50.5.64/27 [90/2195456] via 150.50.7.7, 00:04:30, Ethernet0 / 0

R5 # sh dialer

BRI0 / 0 - dialer type = ISDN

Dial String Successes failures Last DNIS Last status
8995202 0 1 00:16:01 failed
8995201 3 1 00:15:17 successful
0 incoming call (s) have been screened.
0 incoming call (s) rejected for callback.

BRI0 / 0:1 - dialer type = ISDN
Idle timer (60 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

BRI0 / 0:2 - dialer type = ISDN
Idle timer (60 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

R5 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
D 200.0.0.8 [90/2323456] via 150.50.7.7, 00:04:55, Ethernet0 / 0
D EX 200.0.0.9 [170/284160] via 150.50.7.6, 00:04:55, Ethernet0 / 0
D 200.0.0.1 [90/2323456] via 150.50.100.2, 00:05:05, Serial0 / 0
D 200.0.0.2 [90/2297856] via 150.50.100.2, 00:05:05, Serial0 / 0
D 200.0.0.4 [90/2809856] via 150.50.100.2, 00:05:05, Serial0 / 0
C 200.0.0.5 is directly connected, Loopback0
D 200.0.0.7 [90/409600] via 150.50.7.7, 00:04:55, Ethernet0 / 0
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2707456] via 150.50.100.2, 00:05:05, Serial0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32 [170/284160] via 150.50.7.6, 00:04:55, Ethernet0 / 0
D 150.50.4.0/24 [90/2221056] via 150.50.7.7, 00:04:55, Ethernet0 / 0
D EX 150.50.6.0/25 [170/284160] via 150.50.7.6, 00:04:58, Ethernet0 / 0
C 150.50.7.0/25 is directly connected, Ethernet0 / 0
C 150.50.9.0/26 is directly connected, BRI0 / 0
D 150.50.17.0/24 [90/2195456] via 150.50.100.2, 00:05:07, Serial0 / 0
D 150.50.24.0/24 [90/2681856] via 150.50.100.2, 00:05:07, Serial0 / 0
C 150.50.100.0/27 is directly connected, Serial0 / 0
D 150.50.5.64/27 [90/2195456] via 150.50.7.7, 00:04:58, Ethernet0 / 0

R8 # sh run
!
hostname R8
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication username-prompt "Who is it _"
aaa authentication login default local-case enable
enable password cisco
!
username privilege 15 password 0 minhdq vnpro
username password 0 vnpro minhdp
username password 0 vnpro minhdq
ip subnet-zero
100 crypto ISAKMP policy
hash md5
authentication pre-share
vnpro1 address 150.50.17.1 crypto ISAKMP key
!
crypto ipsec transform-set ah-md5-hmac MYSET esp-des
!
MYMAP 110 crypto map ipsec-ISAKMP
set peer 150.50.17.1
set transform-set MYSET
match address 120
!
!
interface Loopback0
ip address 200.0.0.8 255 255 255 255
!
interface Ethernet0 / 0
ip address 150.50.4.8 255.255.255.0
no keepalive
half-duplex
!
interface Serial0 / 0
ip address 150.50.5.69 255 255 255 224
no fair-queue
clockrate 64000
crypto map MYMAP
!
router eigrp 100
network 150.50.4.0 0.0.0.255
network 150.50.5.64 0.0.0.31
network 200.0.0.8 0.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
router rip
version 2
network 150.50.0.0
network 200.0.0.0
!
ip classless
ip route 192.168.10.0 255.255.255.0 150.50.5.68
no ip http server
!
access-list 120 permit ip 150.50.4.0 0.0.0.255 192.168.10.0 0.0.0.255
!
dial-peer cor custom
end

R8 # sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - Candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
C 200.0.0.8 is directly connected, Loopback0
D EX 200.0.0.9 [170/2198016] via 150.50.5.68, 00:27:17, Serial0 / 0
D 200.0.0.1 [90/2861056] via 150.50.5.68, 00:07:13, Serial0 / 0
D 200.0.0.2 [90/2835456] via 150.50.5.68, 00:07:13, Serial0 / 0
D 200.0.0.4 [90/3347456] via 150.50.5.68, 00:07:13, Serial0 / 0
D 200.0.0.5 [90/2323456] via 150.50.5.68, 00:27:17, Serial0 / 0
D 200.0.0.7 [90/2297856] via 150.50.5.68, 00:27:17, Serial0 / 0
S 192.168.10.0/24 [1 / 0] via 150.50.5.68
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/3245056] via 150.50.5.68, 00:07:13, Serial0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32 [170/2198016] via 150.50.5.68, 00:27:17, Serial0 / 0
C 150.50.4.0/24 is directly connected, Ethernet0 / 0
D EX 150.50.6.0/25 [170/2198016] via 150.50.5.68, 00:27:20, Serial0 / 0
D 150.50.7.0/25 [90/2195456] via 150.50.5.68, 00:27:20, Serial0 / 0
D 150.50.9.0/26 [90/41049600] via 150.50.5.68, 00:27:20, Serial0 / 0
D 150.50.17.0/24 [90/2733056] via 150.50.5.68, 00:07:15, Serial0 / 0
D 150.50.24.0/24 [90/3219456] via 150.50.5.68, 00:07:15, Serial0 / 0
D 150.50.100.0/27 [90/2707456] via 150.50.5.68, 00:17:04, Serial0 / 0
150.50.5.64/27 C is directly connected, Serial0 / 0

R5 # sh run
!
hostname R5
!
enable password cisco
!
username R2 password 0 cisco
isdn switch-type basic-ni
!
interface Loopback0
ip address 200.0.0.5 255 255 255 255
!
interface Ethernet0 / 0
ip address 150.50.7.5 255 255 255 128
half-duplex
!
interface Serial0 / 0
ip address 150.50.100.5 255 255 255 224
encapsulation frame-relay
no fair-queue
frame-relay class TSLAB
frame-relay traffic-shaping
!
interface BRI0 / 0
ip address 150.50.9.5 255 255 255 192
encapsulation ppp
dialer idle-timeout 60
dialer map ip 150.50.9.2 broadcast 8995201
dialer map ip 150.50.9.2 broadcast 8995202
dialer-group 1
isdn switch-type basic-ni
isdn spid1 5101
isdn spid2 5102
ppp callback request
ppp authentication chap
!
router eigrp 100
passive-interface BRI0 / 0
network 150.50.7.0 0.0.0.127
network 150.50.9.0 0.0.0.63
network 150.50.100.0 0.0.0.31
network 200.0.0.5 0.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip route 150.50.17.0 255.255.255.0 150.50.9.2 130
no ip http server
!
map-class frame-relay TSLAB
no frame-relay adaptive-shaping
frame-relay CIR 16000
frame-relay bc 2000
frame-relay be 2500
dialer-list 1 protocol ip permit
!
end

R9 # 150.50.7.7
R7 # sh run
!
hostname R7
!
enable password cisco
!
interface Loopback0
ip address 200.0.0.7 255 255 255 255
!
interface Ethernet0 / 0
ip address 150.50.7.7 255 255 255 128
half-duplex
!
interface Serial0 / 0
ip address 150.50.5.68 255 255 255 224
no fair-queue
!
router eigrp 100
network 150.50.5.64 0.0.0.31
network 150.50.7.0 0.0.0.127
network 200.0.0.7 0.0.0.0
no auto-summary
no eigrp log-neighbor-changes
!
router rip
network 150.50.0.0
network 200.0.0.0
!
ip classless
ip http server
!
end

R7 # sh ip route

Gateway of last resort is not set

200.0.0.0/24 is variably subnetted, 8 subnets, 2 masks
D 200.0.0.8/32 [90/2297856] via 150.50.5.69, 00:28:30, Serial0 / 0
D EX 200.0.0.9/32 [170/284160] via 150.50.7.6, 01:21:15, Ethernet0 / 0
R 200.0.0.0/24 [120 / 1] via 150.50.5.69, 00:00:05, Serial0 / 0
D 200.0.0.1/32 [90/2349056] via 150.50.7.6, 00:07:37, Ethernet0 / 0
[90/2349056] via 150.50.7.5, 00:07:37, Ethernet0 / 0
D 200.0.0.2/32 [90/2323456] via 150.50.7.6, 00:07:37, Ethernet0 / 0
[90/2323456] via 150.50.7.5, 00:07:37, Ethernet0 / 0
D 200.0.0.4/32 [90/2835456] via 150.50.7.6, 00:07:37, Ethernet0 / 0
[90/2835456] via 150.50.7.5, 00:07:37, Ethernet0 / 0
D 200.0.0.5/32 [90/409600] via 150.50.7.5, 00:58:14, Ethernet0 / 0
C 200.0.0.7/32 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2733056] via 150.50.7.6, 00:07:39, Ethernet0 / 0
[90/2733056] via 150.50.7.5, 00:07:39, Ethernet0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
D EX 150.50.6.209/32 [170/284160] via 150.50.7.6, 01:21:17, Ethernet0 / 0
D 150.50.4.0/24 [90/2195456] via 150.50.5.69, 00:28:32, Serial0 / 0
D EX 150.50.6.0/25 [170/284160] via 150.50.7.6, 01:21:17, Ethernet0 / 0
C 150.50.7.0/25 is directly connected, Ethernet0 / 0
D 150.50.9.0/26 [90/40537600] via 150.50.7.5, 00:58:16, Ethernet0 / 0
D 150.50.17.0/24 [90/2221056] via 150.50.7.6, 00:07:39, Ethernet0 / 0
[90/2221056] via 150.50.7.5, 00:07:39, Ethernet0 / 0
D 150.50.24.0/24 [90/2707456] via 150.50.7.6, 00:07:39, Ethernet0 / 0
[90/2707456] via 150.50.7.5, 00:07:39, Ethernet0 / 0
D 150.50.100.0/27 [90/2195456] via 150.50.7.6, 00:09:00, Ethernet0 / 0
[90/2195456] via 150.50.7.5, 00:09:00, Ethernet0 / 0
150.50.5.64/27 C is directly connected, Serial0 / 0
R6 # sh run
!
hostname R6
!
enable password 7 110A1016141D
!
!
class-map HTTP
match access-group 101
class-map FTP
match access-group 102
!
!
policy-map PRIO
class HTTP
bandwidth percent 10
FTP class
bandwidth percent 20
!
ip subnet-zero
!
interface Ethernet0
ip address 150.50.7.6 255 255 255 128
service-policy output PRIO
!
interface Ethernet1
ip address 150.50.6.6 255 255 255 128
service-policy output PRIO
!
interface Serial0
ip address 150.50.100.6 255 255 255 224
encapsulation frame-relay
frame-relay map ip 150.50.100.2 602 broadcast
frame-relay map ip 150.50.100.5 605 broadcast
LMI-type frame-relay cisco
!
router eigrp 100
redistribute ospf 1 metric 1500 100 000 10,255,255
network 150.50.7.0 0.0.0.255
network 150.50.100.0 0.0.0.255
no auto-summary
no eigrp log-neighbor-changes
!
router ospf 1
log-adjacency-changes
redistribute eigrp 100 metric 111 metric-type 1 subnets
network 150.50.6.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
access-list 101 permit tcp any any eq www
access-list 102 permit tcp any any eq ftp
!
end

R6 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
D 200.0.0.8 [90/2323456] via 150.50.7.7, 00:08:25, Ethernet0
O 200.0.0.9 [110/11] via 150.50.6.9, 01:22:52, Ethernet1
D 200.0.0.1 [90/2323456] via 150.50.100.2, 00:08:31, Serial0
D 200.0.0.2 [90/2297856] via 150.50.100.2, 00:08:31, Serial0
D 200.0.0.4 [90/2809856] via 150.50.100.2, 00:08:31, Serial0
D 200.0.0.5 [90/409600] via 150.50.7.5, 00:08:25, Ethernet0
D 200.0.0.7 [90/409600] via 150.50.7.7, 00:08:25, Ethernet0
10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2707456] via 150.50.100.2, 00:08:31, Serial0
150.50.0.0/16 is variably subnetted, 9 subnets, 5 masks
O 150.50.6.209/32 [110/11] via 150.50.6.9, 01:22:52, Ethernet1
D 150.50.4.0/24 [90/2221056] via 150.50.7.7, 00:08:25, Ethernet0
C 150.50.6.0/25 is directly connected, Ethernet1
C 150.50.7.0/25 is directly connected, Ethernet0
D 150.50.9.0/26 [90/40537600] via 150.50.7.5, 00:08:27, Ethernet0
D 150.50.17.0/24 [90/2195456] via 150.50.100.2, 00:08:33, Serial0
D 150.50.24.0/24 [90/2681856] via 150.50.100.2, 00:08:33, Serial0
C 150.50.100.0/27 is directly connected, Serial0
D 150.50.5.64/27 [90/2195456] via 150.50.7.7, 00:08:27, Ethernet0

R6 # sh fr
R9 # sh run
!
hostname R9
!
interface Loopback0
ip address 200.0.0.9 255 255 255 255
!
Loopback1 interface
ip address 150.50.6.209 255 255 255 128
!
interface Ethernet0 / 0
ip address 150.50.6.9 255 255 255 128
half-duplex
!
router ospf 63
log-adjacency-changes
network 150.50.6.0 0.0.0.127 area 0
network 150.50.6.128 0.0.0.127 area 0
network 200.0.0.9 0.0.0.0 area 0
!
end

R9 # sh ip route

Gateway of last resort is not set

200.0.0.0/32 is subnetted, 7 subnets
E1 O 200.0.0.8 [110/121] via 150.50.6.6, 00:29:58, Ethernet0 / 0
C 200.0.0.9 is directly connected, Loopback0
E1 O 200.0.0.1 [110/121] via 150.50.6.6, 00:09:55, Ethernet0 / 0
E1 O 200.0.0.2 [110/121] via 150.50.6.6, 00:09:55, Ethernet0 / 0
E1 O 200.0.0.4 [110/121] via 150.50.6.6, 00:09:55, Ethernet0 / 0
E1 O 200.0.0.5 [110/121] via 150.50.6.6, 00:59:43, Ethernet0 / 0
E1 O 200.0.0.7 [110/121] via 150.50.6.6, 01:23:26, Ethernet0 / 0
10.0.0.0/24 is subnetted, 1 subnets
O E1 10.1.1.0 [110/121] via 150.50.6.6, 00:09:57, Ethernet0 / 0
150.50.0.0/16 is variably subnetted, 9 subnets, 4 masks
150.50.6.128/25 C is directly connected, Loopback1
O E1 150.50.4.0/24 [110/121] via 150.50.6.6, 00:29:54, Ethernet0 / 0
C 150.50.6.0/25 is directly connected, Ethernet0 / 0
O E1 150.50.7.0/25 [110/121] via 150.50.6.6, 01:23:28, Ethernet0 / 0
O E1 150.50.9.0/26 [110/121] via 150.50.6.6, 00:59:45, Ethernet0 / 0
O E1 150.50.17.0/24 [110/121] via 150.50.6.6, 00:09:57, Ethernet0 / 0
O E1 150.50.24.0/24 [110/121] via 150.50.6.6, 00:09:57, Ethernet0 / 0
E1 O 150.50.100.0/27 [110/121] via 150.50.6.6, 00:19:47, Ethernet0 / 0
O E1 150.50.5.64/27 [110/121] via 150.50.6.6, 01:23:28, Ethernet0 / 0