Search This Blog

Oct 7, 2010

Lab 1-1: Basic Switch Configuration





Implementation 
1. Run the source of the switch. Hyper Terminal interface is the initialization parameters during startup switch. 

% Please answer 'yes' or 'no'. 
Would you like to enter the initial configuration dialog? [Yes / no]: no 
Press RETURN to get started! 
00:04:13:% LINK-5-Changed: Interface VLAN1, changed state to administratively down 
00:04:14:% LINEPROTO-5-UPDOWN: Line protocol on Interface VLAN 1, changed state to down 
Users will be asked if you want the dialog to configure the automatic answer NO (the user's purpose is wanted in CLI mode (command line interface). 


2. In enable mode to see the default configuration of the switch 


Switch> enable 
Switch # show running-config 
Building configuration ... 
Current configuration: 1473 bytes 
! 
Version 1.12 
! 
hostname Switch 
! 
ip subnet-zero 
! 
spanning-tree mode pvst 
spanning-tree extend system-id 
! 
interface FastEthernet0 / 1 
no ip address 
! 
interface FastEthernet0 / 2 
no ip address 
! 
interface FastEthernet0 / 3 
no ip address 
! 
interface FastEthernet0 / 4 
no ip address 
! 
interface FastEthernet0 / 5 
no ip address 
! 
interface FastEthernet0 / 6 
no ip address 
! 
interface FastEthernet0 / 7 
no ip address 
! 
interface FastEthernet0 / 8 
no ip address 
! 
interface FastEthernet0 / 9 
no ip address 
! 
interface FastEthernet0/10 
no ip address 
! 
interface FastEthernet0/11 
no ip address 
! 
interface FastEthernet0/12 
no ip address 
! 
interface GigabitEthernet0 / 1 
no ip address 
! 
interface GigabitEthernet0 / 2 
no ip address 
! 
interface VLAN1 
no ip address 
shutdown 
! 
ip classless 
ip http server 
! 
line con 0 
line vty 5 15 
! 
end 


3. Setting the parameters for the switch, such as hostname, enable password, console and virtual terminal password password. The type of password is used to distinguish lowercase and uppercase. Distribution so that users need to know the characters use different capital letters lowercase. Other examples for Cisco Cisco. 


Switch # config terminal 
Enter configuration commands, one per line. End with CNTL / Z. 
Switch (config) # hostname Vnpro 
Vnpro (config) # enable password cisco 
Vnpro (config) # enable secret class 
Vnpro (config) # line console 0 
Vnpro (config-line) # password console 
Vnpro (config-line) # login 
Vnpro (config-line) # ^ Z 


Line Virtual Switch support for telnet sessions. Need to configure the password for this new line can telnet to the switch (sequence configuration support telnet will present later).To view information on the Virtual Line Switch: use the "show line". 


Vnpro # show line 
Tty Typ Tx / Rx A Modem Roty AccO ACCI overruns Int Uses Noise 
* 0 CTY - - - - - 0 0 0 / 0 - 
1 VTY - - - - - 0 0 0 / 0 - 
2 VTY - - - - - 0 0 0 / 0 - 
3 VTY - - - - - 0 0 0 / 0 - 
4 VTY - - - - - 0 0 0 / 0 - 
5 VTY - - - - - 0 0 0 / 0 - 
6 VTY - - - - - 0 0 0 / 0 - 
7 VTY - - - - - 0 0 0 / 0 - 
8 VTY - - - - - 0 0 0 / 0 - 
9 VTY - - - - - 0 0 0 / 0 - 
10 VTY - - - - - 0 0 0 / 0 - 
11 VTY - - - - - 0 0 0 / 0 - 
12 VTY - - - - - 0 0 0 / 0 - 
13 VTY - - - - - 0 0 0 / 0 - 
14 VTY - - - - - 0 0 0 / 0 - 
15 VTY - - - - - 0 0 0 / 0 - 
16 VTY - - - - - 0 0 0 / 0 - 


Configure the password for the vty line 
Vnpro # config terminal 
Enter configuration commands, one per line. End with CNTL / Z. 
Vnpro (config) # line vty 0 4 
Vnpro (config-line) # password cisco 
Vnpro (config-line) # login 


Cisco configuration on the device, each command typed by the user. After pressing "enter" the system configuration will change immediately. So, for the real network, before changing a certain parameter of the device, need to backup the original configuration to be restored when necessary. 


Step 4: VLAN configuration. 
Check the default VLAN configuration on Switch 
Vnpro # show vlan 
VLAN Name Status Ports 
1 default active Fa0 / 1, Fa0 / 2, Fa0 / 3, Fa0 / 4 
Fa0 / 5, Fa0 / 6, Fa0 / 7, Fa0 / 8 
Fa0 / 9, Fa0/10, Fa0/11, Fa0/12 
Fa0/13, Fa0/14, Fa0/15, Fa0/16 
Fa0/17, Fa0/18, Fa0/19, Fa0/20 
Fa0/21, Fa0/22, Fa0/23, Fa0/24 
Gi0 / 1, Gi0 / 2 
1002 FDDI-default active 
1003 token-ring-default active 
Fddinet-default active 1004 
Trnet-default active 1005 


VLAN Type SAID MTU Parent RingNo BridgeNo BrdgMode Trans1 Trans2 STP 
---- ----- ---------- ----- ------ ------ -------- ---- - ------ ------ ------ 
1 enet 100001 1500 - - - - - 0 0 
FDDI 101 002 1002 1500 - - - - - 0 0 
1003 tr 101003 1500 - - - - - 0 0 
Fdnet 1004 1500 101 004 - - - IEEE - 0 0 
Trnet 1005 1500 101 005 - - - ibm - 0 0 
Remote SPAN VLANs 
-------------------------------------------------- ---------------------------- 
Primary Secondary Type Ports 
------- --------- ----------------- ----------------- ------------------------- 
Switch default only VLAN 1 with all ports are in this VLAN, VLAN 1002 for FDDI, dedicated VLAN 1003 TOKEN-RING ... There are two ways to create more VLAN 
Option 1: Actions on the VLAN database 
Vnpro # vlan database 
Vnpro (vlan) # vtp domain Chuyenviet 
Changing VTP domain name from NULL to Chuyenviet 
Vnpro (vlan) # vtp server 
Setting device to VTP SERVER mode. 
Vnpro (vlan) # vlan 10 name Admin 
VLAN 10 added: 
Name: Admin 
Vnpro (vlan) # vlan 20 name User 
VLAN 20 added: 
Name: User 
Vnpro (vlan) # apply 
APPLY completed. 
Vnpro (vlan) # exit 
APPLY completed. 
Exiting .... 
Method 2: direct interaction necessary to create VLAN 
Vnpro (config) # interface vlan 10 
Vnpro (config-if) # exit 
Vnpro (config) # 
Vnpro (config) # interface vlan 20 
Vnpro (config-if) # exit 
Vnpro (config) # 
To assign ports to the VLAN, perform these steps: 
For example we need to assign the port FastEthernet 2 into VLAN 10, port 3 to VLAN 20 fastetehnet 
Vnpro (config) # interface fastethernet0 / 2 
Vnpro (config-if-range) # switchport access vlan 10 
Vnpro (config-if-range) # exit 
Vnpro (config) # interface fastethernet0 / 3 
Vnpro (config-if-range) # switchport access vlan 20 
Vnpro (config-if-range) # exit 
Check the VLAN configuration 
Vnpro # show vlan 
VLAN Name Status Ports 
---- -------------------------------- --------- ----- -------------------------- 
1 default active Fa0 / 1, Fa0 / 4, Fa0 / 5, Fa0 / 6 
Fa0 / 7, Fa0 / 8, Fa0 / 9, Fa0/10 
Fa0/11, Fa0/12, Fa0/13, Fa0/14 
Fa0/15, Fa0/16, Fa0/17, Fa0/18 
Fa0/19, Fa0/20, Fa0/21, Fa0/22 
Fa0/23, Fa0/24, Gi0 / 1, Gi0 / 2 
10 Admin active Fa0 / 2 
20 User active Fa0 / 3 
1002 FDDI-default active 
1003 token-ring-default active 
Fddinet-default active 1004 
Trnet-default active 1005 
IP configuration for interface VLAN: the VLAN interface IP configuration logic is nature. The IP service management, IP address of this logic can be used to telnet to the switch remotely and run applications SNMP. 
Vnpro # config terminal 
Enter configuration commands, one per line. End with CNTL / Z. 
Vnpro (config) # interface vlan 10 
Vnpro (config-if) # ip address 10.0.0.1 255.255.255.0 
Vnpro (config-if) # no shutdown 
Vnpro (config-if) # ^ Z 
00:14:43:% LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down 
00:14:43:% SYS-5-CONFIG_I: Configured from console by console 
Save configuration to NVRAM 
Vnpro # copy running-config startup-config 
Destination filename [startup-config]? 
Building configuration ... 
[OK] 
Noting assigned to the switch by default-gateway command 
VnPro # ip default-gateway 10.0.0.100 
10.0.0.100 address can be used as the address of the PC is used to telnet into the switch.

Lab 1-1: Basic Switch Configuration 


Description
Configure the basic parameters for Catalys Switch with the CLI command line interface. The task should take, including the name switch, configure the VLAN interface, configured to telnet into the switch .... Using a workstation connected to the switch via console connection, interactive user interface using HyperTerminal. This is a tool of MS Windows support.