Search This Blog

Oct 6, 2010

Lab 2-1: RIP EQUAL-COST LOAD BALANCING

Description 
This exercise describes how load balancing activities with the RIP cost equally, consider how the switching process switching and fast-switching. RouterB has two lines to the 10.0.0.0 network. Use debug commands to check the package on the way to the 10.0.0.0 network in case of load balancing on each package (per packet) and to each destination (per destination). 


Configuration 
RouterA 
! 
hostname RouterA 
! 
! 
ip subnet-zero 
! 
! 
interface Ethernet0 / 0 
ip address 10.0.0.1 255.255.255.0 
! 
interface Serial0 / 0 
ip address 192.168.1.2 255.255.255.0 
! 
router rip 
network 10.0.0.0 
network 192.168.1.0 
! 
ip classless 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end 
RouterB 
! 
hostname RouterB 
! 
ip subnet-zero 
! 
interface FastEthernet0 / 0 
ip address 192.168.3.1 255.255.255.0 
! 
interface Serial0 / 0 
ip address 192.168.1.1 255.255.255.0 
clockrate 56000 
! 
interface Serial0 / 1 
ip address 192.168.2.1 255.255.255.0 
clockrate 56000 
! 
router rip 
network 192.168.1.0 
network 192.168.2.0 
network 192.168.3.0 
! 
ip classless 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end 
RouterC 
! 
hostname RouterC 
! 
ip subnet-zero 
! 
! 
interface FastEthernet0 / 0 
ip address 10.0.0.2 255.255.255.0 
! 
interface Serial0 / 0 
ip address 192.168.2.2 255.255.255.0 
! 
router rip 
network 10.0.0.0 
network 192.168.2.0 
! 
ip classless 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end 
Implementation 

1. Initially configured to run RIP on all routers. 
RouterA (config) # router rip 
RouterA (config-router) # network 192.168.1.0 
RouterA (config-router) # network 10.0.0.0 
Check the routing table on RouterB, RouterB has two lines to the network 10.0.0.0 
RouterB # sh ip route 
Gateway of last resort is not set 
R 10.0.0.0 / 8 [120 / 1] via 192.168.1.2, 00:00:17, Serial0 / 0 
[120 / 1] via 192.168.2.2, 00:00:13, Serial0 / 1 
C 192.168.1.0/24 is directly connected, Serial0 / 0 
C 192.168.2.0/24 is directly connected, Serial0 / 1 
C 192.168.3.0/24 is directly connected, FastEthernet0 / 0 

RIP will automatically balance the load on the route costs are equal (both route metric is 1). 
 There are three criteria for decision-making following the route: 
Metric: the routing protocol used to calculate the path metric which is the best path to a remote network. Many routing protocols do not easily share information because the metric of the protocols that are different 
AD: If more than one routing protocol running on the router, the value of AD is used to choose which protocol to update routing tables. This value indicates which protocol is the most reliable source. 
Prefix length: transition package will use the route when the destination subnet match. It will select the path length prefix match with the largest network address. 

2. RouterB to load balance based on each package (per packet) both interface S0 / 0 and S0 / a type of switch used to process switching. Process switching networks require routers need to consider in each packet against the routing table, to select the appropriate line. In contrast, fast switching is only done to see the routing table for the first packet, the router then save the results in a high-speed cache and uses the information in the cache to forward the packet to the destination. Fast switching is the default setting. 
To enable process switching on the serial port using the following command 
 

RouterB (congig) # int S0 / 0 
RouterB (config-if) # no ip route-cache 
RouterB (config) # int S0 / 1 
RouterB (config-if) # no ip route-cache 

Check off fast switching on the interface using the command show ip interface 
RouterB # show ip interface S0 / 0 
Serial0 is up, line protocol is up 
Internet address is 192.168.1.1 255.255.255.0 
Broadcast address is 255255255255 
Address determined by non-volatile memory 
MTU is 1500 bytes 
Helper address is not set 
Directed broadcast forwarding is enabled 
Outgoing access list is not set 
Inbound access list is not set 
Proxy ARP is enabled 
Security level is default 
Split horizon is enabled 
ICMP redirects are always sent 
ICMP unreachables are always sent 
ICMP mask replies are never sent 
IP fast switching is disabled 
... 
3. Because there are two routes to a destination in the routing table, half of the package will be sent on a road, and half the other posts on the road. Debug ip packet command to view IP packet received on a router posts 
RouterB # debug ip packet 
From the workstation ping 10.0.0.1. View messages appear, send IP packets balance on two lines to stop the debug undebug execute all (or u all). 
01:42:24: IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 0), 
g = 192.168.1.2, len 60, forward 
01:42:24: IP: s = 10.0.0.1 (Serial0 / 0), d = 192.168.3.2 (FastEthernet0 / 0), 
g = 192.168.3.2, len 60, forward 
01:42:25: IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 1), 
g = 192.168.2.2, len 60, forward 
01:42:26: IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 0), 
g = 192.168.1.2, len 60, forward 
01:42:26: IP: s = 192.168.3.1 (local), d = 255 255 255 255 (FastEthernet0 / 0), 
len 92, sending broad / multicast 
01:42:26: IP: s = 192.168.1.1 (local), d = 255 255 255 255 (Serial0 / 0), 
len 72, sending broad / multicast 
01:42:26: IP: s = 192.168.2.1 (local), d = 255 255 255 255 (Serial0 / 1), 
len 72, sending broad / multicast 
01:42:27: IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 1), 
g = 192.168.2.2, len 60, forward 
The notice slightly complicated by the ping request, ping relply, RIP updates will appear. To filter the information needed to create access-list on the router. Because only want to see ping request packets to the 10.0.0.0 network, create access-list is as follows: 
RouterB (config) # access-list 101 permit icmp 10.0.0.0 0.255.255.255 any 
Access-list applied to filter the messages from the debug commands: 
RouterB # debug ip packet 101 
IP packet debugging is on for access list 101 
Repeat the ping command to 10.0.0.1 from the workstation, see the results. 
IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 0), g = 192.168.1.2, 
len 60, forward 
IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 1), g = 192.168.2.2, 
len 60, forward 
IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 0), g = 192.168.1.2, 
len 60, forward 
IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 1), g = 192.168.2.2, 
len 60, forward 
4. After checking on each packet load balancing, load balancing configuration on each destination as follows. Both of RouterB serial interface mode with fast switching command 
RouterB (config-if) # ip route-cache 
With fast switching, the appropriate information in the first packet of data stream is saved (cached) so CPU is not processing the next packet in a data stream. Check the fast switching enabled by the command show ip interface. Routing tables consider only once on each landing next to a host of packages and go the same way. Routers need only consider the routing table to another destination network cache expires. Turn on debug ip packet 101 on RouterB, and ping 10.0.0.1 from the workstation. When fast switching enabled, only a notice to appear. Package was sent out interface S0 / 0 
RouterB # 
IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.1 (Serial0 / 0), g = 192.168.1.2, 
len 60, forward 
Continue, ping 10.0.0.2, the package will be sent out interface S0 / 1 
IP: s = 192.168.3.2 (FastEthernet0 / 0), d = 10.0.0.2 (Serial0 / 1), g = 192.168.2.2, 
len 60, forward 
5. Try to ping the address 10.0.0.3 and 10.0.0.4 of course there will be no answer, use the command show ip cache to view the content of the route cache. Note that the table cache is available 10.0.0.1 and 10.0.0.2 as well as all IP addresses on network 10.0.0.0, which ping implementation. 
RouterB # show ip cache 
5 IP routing cache entries, 848 bytes 
ADDS 14, 9 invalidates, 0 refcounts 
Minimum invalidation interval 2 seconds, maximum interval 5 seconds, 
quiet interval 3 seconds, threshold 0 requests 
Invalidation rate 0 in last second, 0 in last 3 seconds 
Last full cache invalidation occurred 01:40:00 ago 
Prefix / Length Age Interface Next Hop 
10.0.0.1/32 00:00:15 Serial0 / 0 192.168.1.2 
10.0.0.2/32 00:03:19 Serial0 / 1 192.168.2.2 
10.0.0.3/32 00:00:57 Serial0 / 0 192.168.1.2 
10.0.0.4/32 00:00:43 Serial0 / 1 192.168.2.2 
192.168.3.2/32 00:03:37 FastEthernet0 / 0 192.168.3.2